so库和jar包版本不匹配

0 投票
使用产品:SuperMap iMobile 10i 操作系统:android8.0 设备型号:华为EVA-AL00
问题详细描述:

Environment初始化报错:so库和jar包版本不匹配

问题重现步骤: 1.
6月 29 分类:  70次浏览 | 用户: ouwen (8 分)

1个回答

0 投票

您好,根据报错信息从以下方面排查:
1、确认导入的工程中libs中的so库和jar包是否同一个版本;
2、确认许可是否正常,测试手机的设备系统时间是否正常;
3、运行工程前将原来已生成的该软件卸载,再重新运行安装。
4、如果还是有问题,建议你删除导致那个不兼容的同名文件,可以删超图的jar包或者第三方sdk中的,根据自己的功能需求而定。
5.目前支持armeabi-v7a, 没有64位的库,请在libs目录下仅使用这个,或者AndroidStudio的gradle中配置ndk,仅使用armeabi-v7a.

6月 29 用户: 董懿鑫 登峰造极 (5,793 分)

我的androidstudio版本是

classpath 'com.android.tools.build:gradle:3.6.3'

改成

classpath 'com.android.tools.build:gradle:3.4.1'

就行了,不知道什么原因。

...