vue-cesium-supermap使用缺少 PlotEditControl

0 投票
npm 6.12.0
node v12.13.0

vue 2.6.11

@vue/cli 4.4.4

"vue-cesium-supermap": "^1.0.3",

打印Cesium发现没有

Cesium.PlottingLayer

Cesium.PlotEditControl

Cesium.PlotDrawControl

更多的因为是新手没有用到
6月 23 分类:  280次浏览 | 用户: 1975858873qq.com 才疏学浅 (12 分)

1个回答

0 投票
6月 23 用户: 三次鱼疯啦 名扬四海 (1,969 分)

这个我试过了报下面的错

我这边测试了一下是没有出现您的问题的,请您按照博客中的步骤再尝试一下。
这个您可能处理过了把,我见有的是要把引入的Cesium文件夹要在wekpack中配置下

http://support.supermap.com.cn:8090/webgl/download.html 而且我用的包是从这个网站上新下载的,会不会和你的不一样

您好,您试一下资源中心的这个版本吧。(http://support.supermap.com.cn/DownloadCenter/DownloadPage.aspx?id=1220

打包后发现少了一个js,但是能运行。static/Cesium/Workers/zlib.min.js  这个js重要吗,这个从哪里获取

新的版本的包是没有这个js的,您是按照我给您的链接创建的项目么?应该不会出现这个问题的。
是的,你文章中写的有引用这个js
...