webgl什么时候能有新的稳定版,矢量瓦片问题汇总。

1 投票

目前超图管网所能下载的最新webgl包矢量瓦片加载功能存在以下问题,我前面也都反馈过,如下所示:

请问,超图官方这些问题是否在解决中,超图管网能否提供最新的稳定版下载。

1.webgl中矢量瓦片最大只能请求到19级。

问题链接:webgl 矢量瓦片只支持19级吗?

问题链接:webgl中添加超图发布的矢量瓦片服务相关

2.对接不了iserver9D发布的矢量瓦片服务,只能是isever10i以上的。

问题链接:webgl不支持iserver9D发布的矢量瓦片吗?

3.scene.addVectorTilesLayer对接矢量瓦片需要引用js/ol-debug.js插件。

问题链接:webgl对接mvt矢量瓦片相关

4.加载矢量瓦片后,原分屏功能无法正常使用。

问题链接:iClient 3D for WebGL(10i)缺陷,矢量瓦片和分屏冲突

5.针对矢量瓦片中的要素对象,没有提供相关选择事件。

问题链接:webGL中 矢量瓦片点击选中事件

问题链接:实体点击不起作用,viewer.selectedEntityChanged

5月 18 分类:  97次浏览 | 用户: 行者不懂 牛刀小试 (200 分)

1个回答

0 投票
 
已采纳

您好,上面问题我这边一一回复

1.webgl中矢量瓦片最大只能请求到19级

该问题已经反馈给研发,正在解决中

2.对接不了iserver9D发布的矢量瓦片服务,只能是isever10i以上的。

后续对接矢量瓦片只维护该接口scene.addVectorTilesMap,建议使用新的实现方式来加载MVT矢量数据。

3.scene.addVectorTilesLayer对接矢量瓦片需要引用js/ol-debug.js插件。

新接口scene.addVectorTilesMap不再需要ol-debug.js插件。

4.加载矢量瓦片后,原分屏功能无法正常使用。

您目前提出的问题,目前已提交至研发解决,该缺陷我会与研发详细讨论,预计三天内回复您问题进展,还请耐心等待。非常感谢您提出的这个问题,让我们产品越来越完善。

5.针对矢量瓦片中的要素对象,没有提供相关选择事件。

选中矢量瓦片后会触发 viewer.selectedEntityChanged事件

总结,问题2,3,5最新版本已经修复,如果需要稳定临时包,可联系销售,向超图技术支持中心申请

问题1,为已知问题,研发正在解决,问题4,我这边确认后会回复您,如果确认是缺陷,到时候麻烦您

私信我一下您的单位信息,姓名和手机号,方便解决后,能及时联系到您。

5月 19 用户: 胡林 登峰造极 (5,985 分)
采纳于 5月 20 用户:行者不懂
...