Linux Qt5 编译 sample 无法运行

0 投票

下载 C++ Linux 版 iObjects 组件(9.1.1)后, GettingStarted 编译成功后, 执行到这里

UGGraphicsManager::SetCurGraphicsType(UGGraphics::GT_QT);

出错。与 iObjects c++在Ubuntu下无法运行 应该一样,Qt 5.9.2,Qt 5 以上还是有问题吗?

另,运行 sample 下例子需要许可吗?

使用 Qt 4.8.7 可以正常运行. 但是 Qt5 都出来好些年头了, 什么时候能支持 Qt5? 

7月 2, 2019 分类:  205次浏览 | 用户: xiaofeng 才疏学浅 (19 分)
修改于 7月 2, 2019 用户:xiaofeng

2 个回答

0 投票
您好,很抱歉,目前不支持Qt5版本的qt库. Qt5的支持在计划中,具体时间尚不确定。
7月 2, 2019 用户: 幸俊 学富五车 (694 分)
0 投票
你好,请问下你例子运行成功了吗?

    //初始化工作空间
    m_pWorkspace = new UGWorkspace();

    //初始化一个空的地图,用于图像的输出
    m_pMap = new UGMap();

我的老在这个地方就死掉了
12月 21, 2020 用户: ztt12345 才疏学浅 (11 分)
...