使用超图安卓端track的Demo

0 投票

如图  好多类找不到  不知道是不是少了什么包

6月 10 分类:  68次浏览 | 用户: anber (4 分)

1个回答

0 投票
你好,我们的demo是不带有jar包的。请问你是否有单独将 jar 包添加到工程依赖。

引用方式:eclipse:右键工程--Properties(属性)--选择“Java Build Path”,选择“Libraries,单击“Add JARs…”,选择添加进工程的 SuperMap iMobile Jar包,点击OK完成。

Android studio:可以将我们所需要的jar包拷贝到libs文件夹中,然后选中jar包右键add as library来完成jar包依赖的配置。

具体的引用方式步骤可以查看我们的帮助文档开发指南--基于ADT Bundle开发专业移动GIS程序和基于Android studio开发专业移动GIS程序
6月 10 用户: 董懿鑫 名扬四海 (3,422 分)

这些jar包我全都放进去了  还是这样子 还有其他的jar包吗 还是我引错了

你好,我看你的截图使用的是iMobile Lite的jar包,你这个demo使用的是iMobile for Android的jar包。你需要重新引用一下iMobile for Android的jar包。

我导入了map的包 v911  v912 都试了  缺少一些方法 是哪里做错了吗 感谢

你好,检查一下你的Map是不是引用错了,需要引用我们产品中的:

import com.supermap.mapping.Map;
问题完美解决 非常感谢
...