首页 / 浏览问题 / 云GIS / 问题详情
超图FAQ:攻防演练中iServer服务被攻击,监测发现外网地址针对主机的命令注入探测请求,攻击者请求/iserver/Iserver.jsp并携带系统执行命令尝试删除页面文件,需解决攻击问题并加固服务
69,553EXP 2026年09月30日
攻防演练中iServer服务被攻击,监测发现外网地址针对主机的命令注入探测请求,攻击者请求/iserver/Iserver.jsp并携带系统执行命令尝试删除页面文件,需解决攻击问题并加固服务

1个回答

【问题原因】攻击者通过向服务器上传jsp脚本执行命令注入攻击,iServer 2022及之前版本可能存在文件上传漏洞,11.3.0已修复;远程排查服务器未发现攻击残留文件。【解决办法】在代理外网的nginx配置中添加规则禁止访问jsp(location ~ .jsp$ { return 403; });在iServer中配置文件根目录并在iserver-system.xml中配置deniedFiles禁止.jsp,.sh,.exe,.bat等脚本文件上传,配置后重新选择服务提供者的工作空间文件并重启iServer,即可无法通过iServer上传jsp等脚本文件到根目录执行。
69,553EXP 2026年09月30日
热门文章
关注我们
...