vs2010,qt4.8.5可以开发吗?

0 投票
我查看了文档,我的vs2010的qt版本4.8.5,在windows下开发SMO_CPP_802_13626_55470_Win.zip在文档中没有提到可能出问题。但是我引入Extensions4Qt后,编译通过,但是运行到QMapControl时,产生崩溃,提示各种问题,我选择把qmapcontrol.cpp,qmapcontrol.h加入工程,就执行到m_pMapEditorWnd崩溃。但是Lib和头文件都已经引入。没有问题。只是提示我运行前加载dll,我把SMO_CPP_802_13626_55470_Win\bin\bind对应的文件加入后,提示缺少msvcr110.dll,我在SMO_CPP_802_13626_55470_Win\bin\bind下没有找到这个文件,但是在SMO_CPP_802_13626_55470_Win\bin\bin下找到了。拷贝过去之后,报错误 应用程序无法正常启动(0x000007b),请问怎么解决?
7月 30, 2017 分类:  234次浏览 | 用户: asssasharp 才疏学浅 (17 分)

1个回答

1 投票
C++组件只能在vs2012上面开发,不支持2010。建议使用vs2012,qt4.8.6
7月 31, 2017 用户: 程逸诗 名扬四海 (1,242 分)
...