idesktopx-10.1.2,uos系统ARM版,java运行环境错误

0 投票

鲲鹏ARM版cup,uos专业版1040系统,idesktopx-10.1.2解压后,运行startup.sh,报Java方面出错,一直停留正在初始化环境。

root@UOS-PC:/home/user/Desktop/map/supermap-idesktopx/supermap-idesktopx-10.1.2-0330-5260-86195-linux64-arm-bi0330-5260-86195-linux64-arm-bin-chs# ./startup.sh
an exception caught at Environment.load(), program will continue running.
java.lang.UnsatisfiedLinkError: /home/user/Desktop/map/supermap-idesktopx/supermap-idesktopx-10.1.2-0330-5260-86195-linux64-arm-bin-chs/bin/libWrapjCore.so: /home/user/Desktop/map/supermap-idesktopx/supermap-idesktopx-10.1.2-0330-5260-86195-linux64-arm-bin-chs/bin/libnssutil3.so: version `NSSUTIL_3.38' not found (required by /lib/aarch64-linux-gnu/libssl3.so)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824)
        at java.lang.Runtime.load0(Runtime.java:809)
        at java.lang.System.load(System.java:1086)
        at com.supermap.data.Environment.load(Environment.java:484)
        at com.supermap.data.Environment.LoadWrapJ(Environment.java:425)
        at com.supermap.data.Environment.<clinit>(Environment.java:56)
        at com.supermap.data.InternalHandle.<clinit>(InternalHandle.java:19)
        at com.supermap.desktop.core.GlobalParameters.<clinit>(SourceFile:1176)
        at com.supermap.desktop.core.Application.b(SourceFile:482)
        at com.supermap.desktop.core.Application.initialize(SourceFile:327)
        at com.supermap.desktop.iDesktop.Startup.main(SourceFile:103)
an exception caught at Environment.load(), program will continue running.
java.lang.UnsatisfiedLinkError: /home/user/Desktop/map/supermap-idesktopx/supermap-idesktopx-10.1.2-0330-5260-86195-linux64-arm-bin-chs/bin/libWrapjAnalyst.so: /home/user/Desktop/map/supermap-idesktopx/supermap-idesktopx-10.1.2-0330-5260-86195-linux64-arm-bin-chs/bin/libnssutil3.so: version `NSSUTIL_3.38' not found (required by /lib/aarch64-linux-gnu/libssl3.so)

8月 18 分类:  68次浏览 | 用户: chnyuezhongwen (2 分)

1个回答

0 投票

您这个报错是由于缺少相关依赖库导致的,

解决方法:先将iDesktopX停止,将依赖库压缩包解压后将libssl3.so文件放到iDesktopX安装目录/bin/目录下,最后重新启动iDesktopX即可正常加载了。

依赖库文件已经发您邮箱了。

8月 18 用户: 张定祥 名扬四海 (2,012 分)
谢谢,可以运行了。
...