Vue-iClient-MapboxGL引入报错

0 投票

npm install 之后 npm run serve 报错。按提示install无效

4月 28 分类:  126次浏览 | 用户: luoben_147 (2 分)

2 个回答

0 投票
 
已采纳
你好,你这报错是没有videojs,按照提示再npm install 一下videojs
4月 28 用户: johnJJ 才高八斗 (832 分)
采纳于 4月 29 用户:luoben_147
无效的,试过多次了
你的提示是少了这些依赖包,你install后,又报了啥问题,如果是少依赖,自己安装就是

video.js 安装了 run serve还是报这个。 也更新了node.js版本  提示的找不到的dependencie都安装了还是不行。。 各位大佬没有出现过这个问题吗

我也是这个问题,,暂时还没人回复我

自个看弄,直接npm instal这个js报错找不到这个包,去掉后面的这些直接

npm install --save @videojs/vhs-utils  

还有如果你video.js装上了,那就不会报错了

大佬nb,完美解决!
0 投票
4月 28 用户: 张定祥 名扬四海 (1,532 分)
就是按照文档安装的,新建的vue cli4脚手架项目 然后 npm install @supermap/vue-iclient-mapboxgl  到这里没有问题,然后在main.js 中import VueiClient from '@supermap/vue-iclient-mapboxgl';       Vue.use(VueiClient);    之后npm run serve 运行项目就报错了
请问您解决了吗,我也是这个问题
...