动态自动发光纹理

0 投票

使用产品:SuperMap iClient3D for WebGL 操作系统:win10 x64

问题详细描述:

渲染模型的时候只有colorTable有用,动态自发光没效果

var hyp = new Cesium.HypsometricSetting();
function setHypsometric1(layer) {
                  hyp.emissionTextureArray = [
                    {
                        url:"../image/纹理16.jpg",
                        USpeed:0,
                        VSpeed:0,
                        UTiling:100,
                        VTiling:100
                      }
                  ]
                  hyp.ColorTable = colorTable;
                  layer.hypsometricSetting = {
                    hypsometricSetting: hyp,
                    analysisMode: Cesium.HypsometricSettingEnum.AnalysisRegionMode.ARM_ALL
                  }
                }
              setHypsometric1(layer);

1月 14 分类:  309次浏览 | 用户: j490365867 初出茅庐 (65 分)

1个回答

0 投票
您好,您要设置纹理动态自发光效果的话,需要调整Uspeed和Vspeed不为0,Uspeed是横向速度,Vspeed是纵向速度。
1月 14 用户: KeineAhnung 名扬四海 (1,542 分)

您好,我想实现这样的效果,一个是静态的贴图一个是动态的发光条纹

您好,静态贴图uvspeed为0就可以,动态发光条纹就需要设置速度。

比如{
url: "./images/纹理2.jpg",
USpeed: 0.5,
VSpeed: 0,
UTiling: 30,
VTiling: 30
},

纹理2就是发光条纹,USpeed赋予其动态速度。
hyp.emissionTextureArray = [
                  {
                    url:"../image/speedline.jpg",
                    USpeed:0.25,
                    VSpeed:0,
                    UTiling:100,
                    VTiling:100
                  }, {
                    url:"../image/纹理16.jpg",
                    USpeed:0,
                    VSpeed:0,
                    UTiling:100,
                    VTiling:100
                  },
                ];
                hyp.ColorTable = colorTable;

您好,我的hyp这样设置了之后只有colorTable有效果,这两个纹理贴图动态和静态的都没有效果,模型上没有显示出纹理

您看看贴图路径是否正确呢。

路径是正确的呢,我用hyp.emissionTextureUrl这种方式加载是能成功的,用hyp.emissionTextureArray就失败了

hyp.emissionTextureUrl = '../image/speedline.jpg';

我这边测试两种方式都是有效果的,您的模型是怎么生成缓存的?
是矢量面拉起来的s3m切片缓存
可以留个qq远程看下吗
好的,我的qq是490365867
...