Android 版OnLineDemo 编译报错

0 投票
使用产品:supermap-imobile-10.1.0-206-android-zip-chs_(精简绿色包) 操作系统 win7 x64

问题描述:根据SuperMap iMobile 10i(2020) for Android Guide.pdf的指导配置eclipse 编译环境。可以新建项目并成功编译。

                导入OnLineDemo后在libs里面加入supermap-imobile-10.1.0-206-android-zip-chs_(精简绿色包)中的libs文件夹下面的所有jar文件然后编译,报如下错误:

Errors occurred during the build.
Errors running builder 'Android Package Builder' on project 'OnlineDemo'.
com/android/dx/command/dexer/Main : Unsupported major.minor version 52.0

用cmd 输入 java -versioin 可以查看jdk版本是1.6.0_45
12月 22, 2020 分类:  106次浏览 | 用户: lxlgod (1 分)

1个回答

0 投票
您好,根据报错是因为jdk版本不兼容导致的,您那边可以使用jdk1.8版本来运行工程
12月 22, 2020 用户: 董懿鑫 登峰造极 (7,686 分)
...