so库和jar包版本不匹配

0 投票

新换一个手机做测试,提示

就换了一个手机测试,其他代码,jar都没动,许可用的是之前的,在另一个手机上好用.新手机就报错了.请问怎么回事?

8月 11, 2020 分类:  225次浏览 | 用户: sm 初出茅庐 (23 分)

1个回答

0 投票

您好,根据报错是因为检查64位库导致的。您那边在build.grandle文件中设置ndk:在defaultConfig节点中写下面代码

ndk {
    abiFilters "armeabi-v7a"//armeabi-v7a为so库的文件夹名称
}
8月 11, 2020 用户: 董懿鑫 登峰造极 (7,671 分)

你好,知不知道这个是什么错误,帮忙看下

您好,这是 因为该文件夹不存在或者路径不正确,您那边可以将这句代码注释掉,获取在设备中对应路径创建该文件夹

我不知道这个错误出现在哪,我程序里没有请求这个路径的代码,Environment是配置超图许可的,和这个路径有关系吗?我不知道哪里错了?

你看一下这个路径里面是否有这个文件夹,如果没有可以新建一个。然后看一下设备里面的权限是否都开启了
...