首页 / 浏览问题 / 组件GIS / 问题详情
java用的17导致运行jar包会报错
69EXP 2023年09月21日

之前在windows上开发的jar包,现在要把这个jar包部署在linux上。windows上是用17开发的,也能顺利运行。

环境变量已经配置好了,许可认证也放在目录下了。

我把环境变量从jdk17-bin指向jre1.8(iObject自带的),就会报版本太高的错。而不是像下面一样的错。

除了换jdk,还有什么方法能解决嘛?

1个回答

您好,iobject java需要使用的jdk版本为1.8,暂不支持jdk 17
3,235EXP 2023年09月21日
...