首页 / 浏览问题 / 移动GIS / 问题详情
Android12版本,报错提示无效的许可文件
1EXP 2022年11月04日

如下图所示

1个回答

您好,请问您那边使用的是什么版本的移动端组件呢,还有使用的许可是什么版本呢,如果您不确定,可以在断点中用environment.getlicensestatus()查看许可相关信息,还有确保许可没有被修改过,使用的移动端sdk版本与许可版本保持一致
3,405EXP 2022年11月04日
试用的许可证申请的是SuperMap GIS 11i ,勾选的组件是全选,并且确定该许可没有被修改过,版本也是一致的
如果是试用许可,您应该申请10i版本的应用于11i的移动组件
意思是我申请10i的版本,然后产品选择SuperMap iMobile 这个就行了吗,如果我想试用SuperMap iMobile中的AR 和3D功能是不是也是这么操作?
是的呢,10i与11i用的一样的的哈

我下载的是你门提供的11版本64位的代码,用得是10的申请证书,SO和jar包都是你们下载的连接里面提供的。现在提示不一致,请问是哪里出了问题

看你的libs中的ABI名称不对,用的是32位的,64位该用arm64-v8a
可是我下载的就是你们64的代码和Libs啊,你们提供的就不对,我应该去哪里下载64的arm64-v8a
可以提供一下android AR官网的demo可以吗,任意版本的,只要能正常稳定运行起来就行  64位的
AR范例demo分享地址

链接:https://pan.baidu.com/s/1ErDDteK845v9ko6btvBbqQ
提取码:jjbu

把其中包与库更换为64位即可
...