首页 / 浏览问题 / 其他 / 问题详情
Yukon数据库编译安装找不到-luuid
11EXP 2022年07月29日

我尝试在centos7.9上编译安装yukon数据库,按照yukon官网的编译安装 提示进行前期操作,但是在编译yukon源码时,报错找不到-luuid。

具体错误截图如下:

错误截图中对应的Makefile路径为:../yukon4pgsql-master\geomodel\libUGC\Src\Toolkit。Makefile文件中相关截图如下:

请教各位大佬,有没有遇到过类似问题,或者有哪位大佬晓得这里的uuid是指谁提供的库?(比如是boost提供的组件库?还是Linux系统应该安装的一个库?或者是其他具体谁提供的?)

1个回答

您好,建议尝试使用CentOS7.6版本哈,目前禹贡只适配了该版本。如果一定要使用CentOS7.9的话,建议可以参考 https://blog.csdn.net/liuhongxiangm/article/details/9187627 教程看能否解决找不到 -luuid 的问题。

希望可以帮到您。

2,138EXP 2022年07月29日
...