iserver10i安装失败

0 投票

我的服务器版本是 SUSE Linux Enterprise Server 11 SP4 (x86_64) -kernel

安装的iserver版本是: supermap-iserver-10.2.0-linux64-deploy.tar.gz

我们服务器上安装的jdk是 1.7.0_72(64位),这个jdk应该用的是iserver自带的。

我的操作步骤如下: 

步骤1: 我通过命令tar -zxvf  supermap-iserver-10.2.0-linux64-deploy.tar.gz

步骤2: 进入到support 目录下执行: ./dependencies_check_and_install.sh install -y

步骤3: 进入到 support\objectsjava 目录下对Bin.tar.gz 进行解压

步骤4: 由于我本地以前有过许可了,所以没有对许可进行解压操作

步骤5: 我进入到supermap-iserver-10.2.0-linux64-deploy/bin 目录下执行 是startup.sh 执行启动操作,iserver会将 support\objectsjava  解压的Bin 处理成bin 文件

步骤6: 第一次启动失败,我将Java和iserver端口的进程杀掉,然后进入 support\objectsjava\bin 目录下将

rm -rf libSuEngineSRDB.sdx

rm -rf libSuEngineDMCI.sdx

rm -rf libSuEnginePG.sdx

rm -rf libSuEngineOsp.sdx

rm -rf libSuEngineAltibase.sdx

rm -rf libSuEngineDB2.sdx

rm -rf libSuEngineKDB.sdx

rm -rf libSuEngineKadb.sdx

以下依赖库进行删除,之后重新启动,依旧失败,报错信息如下: 

执行 ldd libWrapj*.so |grep not ,信息如下: 

请问一下,老师这个应该怎样解决呢?

1月 4 分类:  33次浏览 | 用户: 永远有多远1 牛刀小试 (208 分)

1个回答

0 投票
您那边报这个错误是因为系统的glibc版本问题,您那边可以手动将系统自带的glibc版本升级到2.14,然后再重新使用iServer看下。
1月 5 用户: 张定祥 名扬四海 (2,163 分)
...